Ticket #100 (closed: not an issue)

Opened 11 years ago

Last modified 11 years ago

Basic input- Unassimil/ consumption values not saving properly

Reported by: carieh Owned by: jeroens
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description

basically you have to save these values manually (click the save button) to get these values into the core.

model 2E- june 18 imported
In my attempt to balance, I have adjusted the unassimil/ consumption (U/Q) values, yet this is not reflected in the basic estimates screen. I could change the values of U/Q ratio and this has no effect on balancing/ parameterizing.
I should be able to change the U/Q ratio of krill and copepods to 0.42, and benthos to 0.45. this should balance the model, and give an EE=0.988 for detritus. (in case you want to reproduce).- so the changes are not reflected in the parameterization- basic estimates screen.

Actually, I closed this model, and re-opened and the U/Q values were the original imported values, NOT the values I changed them to. So I re-edited the values and saved the model, and Viola!!! It balanced.

So it seems the problem is that where things like Biomass, and P/B ratio automatically get saved when you click the enter button, you have to manually save changes to U/Q, and it will work.

See bug 101

Change History

comment:1 Changed 11 years ago by jeroens

The philosophy behind EwE data saving is that computed values are never saved to the database. Only user inputs values are saved; everything else can be reproduced.

In EwE5, changes made to input variables were immediately saved to the database. In EwE6, we decided to change that behaviour. The user needs to explicitly select a [Save] action for values to store values into the database.

There is one consistent exception: actions that cause items to be created or destroyed (groups, fleets, etc) happen via the database. These changes will 'have stuck' when you open that model again.

So!

The fact that you have to press 'Save' to store changes in the database is not a bug, but is per design, and new in EwE6. Nothing will save unless you actively order it to, either by choosing 'Save' or by answering 'Yes' to a save prompt.

Note: See TracTickets for help on using tickets.