Ticket #1127 (closed assessed: fixed)

Opened 6 years ago

Last modified 6 years ago

Ecospace results grid incorrect for the "End:" period

Reported by: joeb Owned by: joeb
Priority: normal Milestone: Ecopath 6: release 6.3 BETA
Component: Ecospace Version:
Severity: minor Keywords:
Cc:

Description

Under some circumstances the last time step will not contain data. So the end result will be wrong, it is missing data in the last time step. To work around this do not include the last year in the summary period, set the "End:" value to two years less than the Total run time. This does not include the last time step and the data summary will be correct.
This is being caused by rounding error in the main Ecospace time loop. In some circumstances it will not include the last time step.

Change History

comment:1 Changed 6 years ago by joeb

  • Owner set to joeb
  • Status changed from new to assigned

comment:2 Changed 6 years ago by jeroens

Could be related to #1126, first fix that one

comment:3 Changed 6 years ago by joeb

  • Status changed from assigned to closed
  • Resolution set to fixed

Ecospace would sometimes exit the main time loop before the last time iteration due to small rounding error. I made sure it loops to the last time step.

Note: See TracTickets for help on using tickets.