Ticket #116 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Edit multistanza groups not making it to the core

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description

Multi-stanza groups not correctly displayed. In the edit groups, and edit multistanza screens everything is correct. However when I am back at the basic input screen, the cod groups are sorted correctly, but the shading of the blue boxes for phytoplankton, zooplankton, and benthos suggests that these groups are still considered the multi-stanza groups somewhere in the core. The shading blue should be reserved for the ultistanza groups, as I have already entered this information for the cod groups. When I try to enter a biomass for the cod groups I can, but I do get an error when I try to delete.

So I think the model is somewhere in between sorting itself out

There was some error, and I accidentally hit the close button instead of the ignore button, so when I re-opened the model, all of the cod groups were in the correct location .
However- the biomass, P/b, Q/B were NOT saved correctly from opening and closing the model. I re-inputed them closed the model, and re-opened (multi-stanza groups were saved from correct location), but re-opening the model, the multi-stanza screen resets itself.

please see screenshots in july1.doc on the ftp folder.

Change History

comment:1 Changed 11 years ago by administrator

duplicate of #118

comment:2 Changed 11 years ago by jeroens

This issue is the same as bug 120. Some multi-stanza changes make it to the core which explains the change in shading of various boxes. The update bug is limited to the grid rows which are not reordered to reflect a changed stanza layout.

comment:3 Changed 11 years ago by jeroens

Carie, please re-test in v. 6.0.0.15

comment:4 Changed 11 years ago by carieh

In version 16, this issue is still happening. However, if I click the save model group after I have fix/ entered data into the multistanza interface, the values seem to stick. So not a huge problem, but these values should be retained automatically. (may be same issue as 121).

comment:5 Changed 11 years ago by jeroens

Fixed after 6.0.0.16

Note: See TracTickets for help on using tickets.