Ticket #1233 (closed assessed: fixed)

Opened 5 years ago

Last modified 5 years ago

EwE 6.3.8648.0 misses TL of community and Catch PPR in Ecosim Network Analysis

Reported by: ekina Owned by: ekina
Priority: normal Milestone: Ecopath 6: release 6.4 BETA
Component: Network Analysis plug-in Version: 6.3.1
Severity: major Keywords:
Cc: drmbongo@…, ekin@…

Description

In the latest version of EwE 6.3.8648.0, Ecosim Network Analysis under Tools in Ecopath misses mean trophic level of community (mTLco) and primary production required for catches (Catch PPR) indexes in the results file produced by "Save to CSV file" even though "Indexes with primary production required" option is selected. However, Catch PPR is shown on the resulting plot whereas mTLco is not. These ENA indicators used to be present in the results file produced by EwE version 6.1.1 ENA tool as far as remembered.

Steps to reproduce:

  1. Open a model, e.g. Generic 37
  2. Run Ecosim Network Analysis with indexes with primary production required
  3. Select "Save to CSV file" button to save the results and save the results
  4. Open any of the two files to see that Catch PPR and mTLco are missing.

Expected results:
Catch PPR and mTLco should be present in the files produced by "Save to CSV file".

Attachments

ENA_PPR.patch (967 bytes) - added by ekina 5 years ago.
Patch to include PPRc and PPRdet in the CSV when saving ENA results with PPR

Change History

comment:1 Changed 5 years ago by ekina

  • Cc ekin@… added
  • Summary changed from EwE 6.3.8648.0 misses TL ov community and Catch PPR in Ecosim Network Analysis to EwE 6.3.8648.0 misses TL of community and Catch PPR in Ecosim Network Analysis

Changed 5 years ago by ekina

Patch to include PPRc and PPRdet in the CSV when saving ENA results with PPR

comment:2 Changed 5 years ago by ekina

Apparently, the issue of missing Catch_PPR and Catch_Det_Req in the resulting CSV file when saving ENA results with PPR is due to careless copy/paste by a developer. The patch is so simple as you can see in the attached patch file. I created the patch against revision 9009.

On the other hand, the issue of missing mTLco is due to the fact that it is not listed under the indices to be written to the CSV file. I am working on that issue too and will provide a patch if I resolve.

comment:3 Changed 5 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

Indeed, a careless copy/paste bug. Thanks Ekin for pointing this out

Note: See TracTickets for help on using tickets.