Ticket #1254 (closed assessed: fixed)

Opened 5 years ago

Last modified 5 years ago

"Apply best fits" button is not enabled after Monte Carlo simulation

Reported by: ekina Owned by: joeb
Priority: normal Milestone: Ecopath 6: release 6.4 BETA
Component: Monte Carlo Version: 6.3.1
Severity: major Keywords: monte carlo, best fits
Cc: j.steenbeek@…, ekin@…

Description

The SVN built of EwE 6 (6.3.9431.0) does not enable the "Apply best fits" push-button after a Monte Carlo simulation.

Steps to reproduce:

  1. Open model "Georgia Strait".
  2. Move to "Time dynamic (Ecosim)" and select "all fit" scenario.
  3. Load the time series "georgiascaleNEW" by clicking on the "Time Series" tree item on the left pane.
  4. Move to "Monte Carlo simulation" on the left pane.
  5. Switch to "Settings" tab and deselect "Show biomass trajectories on Ecosim plot" and select "Retain better fitting estimates (use trials to search)" options.
  6. Click "Run trials" to run the Monte Carlo simulation.
  7. When the Monte-Carlo simulation ends, see that "Apply best fits" push-button is not enabled although a best fitting trial exists.

Expected behaviour:

The "Apply best fits" button should have been enabled after a best fitting trial was found.

Change History

comment:1 Changed 5 years ago by jeroens

  • Status changed from new to closed
  • Type changed from not assessed to assessed
  • Resolution set to fixed
  • Milestone changed from NOT SET to Ecopath 6: next release

Confirmed. The logic in the MCMC form intended to enabled the 'apply best fit' option only when a better fit was found. However, the check was phrased the wrong way.
Fixed

Note: See TracTickets for help on using tickets.