Ticket #1255 (closed assessed: fixed)

Opened 5 years ago

Last modified 5 years ago

"Save results to .csv" under "Ecosim group plots" and "Save data to .csv..." under "Ecosim all fits" left pane menu items always default to "EwE output" folder under "Documents"

Reported by: ekina Owned by: jeroens
Priority: normal Milestone: Ecopath 6: release 6.4 BETA
Component: Overall GUI Version: 6.3.1
Severity: minor Keywords: save results to csv
Cc: ekin@…, j.steenbeek@…

Description

This is not a bug but a major usability annoyance. In Ecosim, both of the "Save results/data to .csv" options under "Ecosim group plots" and "Ecosim all fits" left pane menu items always default to the "EwE output" folder under user's "Documents" folder. However, it should default either to the "last saved folder" if any results of the loaded model have been previously saved by the user or to the "currently loaded model's folder". Here is a summary of steps to reproduce the behaviour:

  1. Open any model in Ecosim.
  2. Run the Ecosim simulation.
  3. Click the "Ecosim all fits" left pane menu item.
  4. Select "Save plots > Save data to .csv..." and pick a folder other than the default "EwE output" folder in the pop-up window.
  5. Then move to the "Ecosim group plots" left pane menu item.
  6. Click "Save results to .csv..." push button on the bottom right.
  7. Observe that the pop-up window that opens to offer the save location again is reset to the "EwE output" folder.

Expected behaviour:

The program should have remembered the "last saved location" when offering the location in the pop-up window on "Step 7" because previously another "results" has already been saved to a location other than the default. Or as an option, the program may default to the current loaded model's directory rather than the "EwE output" if no results have been saved previously.

Change History

comment:1 Changed 5 years ago by jeroens

  • Status changed from new to assigned
  • Type changed from not assessed to assessed

The folder selection dialog (now improved, see ticket #1266) in this case should revert to the current selected Ecosim output folder, set system wide.

comment:2 Changed 5 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.