Ticket #131 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Basic Input screen- not accessible after using Ecosim

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecopath Version:
Severity: minor Keywords:
Cc:

Description

After running Ecosim, I cannot open the Basic input screen in Ecopath. I can open any other screen (and even the edit groups screen) but not the basic input. I am not sure why?

I also tried to close and re-open the model, but I still cannot get into the basic input screen. Using lab 3 july 25.

As test turned out, the issue is indeed caused by a damaged layout file. Carie has to close the program and restart it for the layout to be properly restored.

Solution is three-fold:
1) Prevent layout files from restoring forms as hidden
2) Ensure that the program does not have to be restarted to reveal hidden

forms; clearing the 'Save Window Layout' option should be enough

3) Add a 'Reset layout' option to Menu > Windows

Change History

comment:1 Changed 11 years ago by jeroens

This *could* be due to a screwed-up layout file. To test this perform the following:

  • Go to Tools > Options > Application
  • If 'Save Window Layout' is checked, do the following:
    • Press [Remove layout file]
    • Clear 'Save Window Layout' check box
    • Close and reopen the model Basic Input should reappear. We need a 'Reset window layout' option, or a detection algorithm that windows from being restored as hidden.

If 'Save Window Layout' was not checked we have indeed a problem ;)

comment:2 Changed 11 years ago by jeroens

Added work-around. Although forms are still saved as hidden, upon activation they will be 'unhidden'

Note: See TracTickets for help on using tickets.