Ticket #1379 (closed assessed: fixed)

Opened 4 years ago

Last modified 4 years ago

Grid export and import logic incompatibility

Reported by: jeroens Owned by: jeroens
Priority: normal Milestone: Ecopath 6: Release 6.5
Component: User Interface Version: 6.4.3
Severity: minor Keywords:
Cc:

Description

Some EwE grids cannot import the data that they exported due to hidden columns.

To reproduce:

  • Open a model without stanza configurations
  • Export the Basic Input grid to a file with the 'save to csv' option in the quick edit toolbar (top-right)
  • Open the csv file in Excel
  • In Excel, select all content, Ctrl+C
  • In EwE Basic Inputs, select the entire grid, Ctrl+V

The export logic mistakenly exports content of the hidden column Z
The paste logic correctly skips content for this hidden column

Change History

comment:1 Changed 4 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

Fixed

Note: See TracTickets for help on using tickets.