Ticket #1432 (closed assessed: fixed)

Opened 3 years ago

Last modified 3 years ago

Bug in SS calculations for catches

Reported by: telmom Owned by: joeb
Priority: high Milestone: Ecopath 6: Release 6.5
Component: Ecosim Version: 6.5 beta
Severity: NOT SET Keywords:
Cc:

Description

We cannot reproduce the calculation of SS for catches. Either we're doing something wrong or there is a bug in EwE

Change History

comment:1 Changed 3 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

VC: catches should not be normalized, only relative time series (biomass) should be so

CW: It is incorrect to be overriding the first ss calculation with the second one (corrected for mean Zstat) for catches and forced catches; it is necessary to estimate q for mean weight data, since the ecosim internal mean weight is not in the same units as users are likely to enter for mean weight data. So the OR condition needs to be removed for etimeseriestype Catch and Catch forcing

JB: I have made the changes to the calculations of SS in PlotDataInfo?(). DataQ() is now only calculated for relative biomass, total mortality and average weight. For all other data types it is set to zero so it will not have any scaling effect. I checked this with a few different catch time series and it does appear to be working correctly.

Note: See TracTickets for help on using tickets.