Ticket #1433 (closed assessed: fixed)

Opened 3 years ago

Last modified 3 years ago

Core state manager not connected properly to core state monitor

Reported by: jeroens Owned by: jeroens
Priority: high Milestone: Ecopath 6: Release 6.5
Component: Overall Logistics Version: 6.5 beta
Severity: major Keywords:
Cc:

Description

Some core actions are not properly protected through the EwE UI, which is caused by the core state manager not properly observing the core busy state.

To give an example:

  • load a model with Ecosim scenarios
  • Run Fit to Time Series or another long operation
  • While the operation is in progress click an Ecospace node.

The New Ecospace Scenario UI pops up, and users can create a scenario while the Fit to Time Series run is in progress.

Eek! This should not be possible while the core state monitor is busy!!

Change History

comment:1 Changed 3 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.