Ticket #1453 (closed assessed: fixed)

Opened 2 years ago

Last modified 2 years ago

Habitat capacity always 0

Reported by: martac Owned by:
Priority: high Milestone: Ecopath 6: Release 6.5
Component: Ecospace Version: 6.5 beta
Severity: major Keywords:
Cc:

Description

Ecospace complains that capacity is always 0, regardless if I use habitats, input capacity, or both. I cannot run Ecospace now

Change History

comment:1 Changed 2 years ago by jeroens

  • Status changed from new to closed
  • Type changed from not assessed to assessed
  • Resolution set to fixed
  • Milestone changed from Ecopath 6: future version to Ecopath 6: Release 6.5

This happens for capacity input maps that are all zero. I've added a fix in Ecospace that assumes an input capacity of 1 for all zero input maps

comment:2 Changed 2 years ago by jeroens

This is a user input error, but because the cause of the error is hard to find the ix is legitimate. Perhaps a different, explicit error message warning of missing data is more proper. The work-around will do for now.

Note: See TracTickets for help on using tickets.