Ticket #1475 (closed assessed: fixed)

Opened 21 months ago

Last modified 21 months ago

Loading Ecospace map may dirty data sources

Reported by: jeroens Owned by:
Priority: low Milestone: Ecopath 6: future version
Component: Ecospace Version: 6.5 beta
Severity: minor Keywords:
Cc:

Description

When first opening the Ecospace map in a newly loaded scenario the datasource may be flagged as dirty, causing an unnecessary save prompt later on.

Change History

comment:1 Changed 21 months ago by jeroens

  • Status changed from new to closed
  • Severity changed from NOT SET to minor
  • Type changed from not assessed to assessed
  • Component changed from NOT SET to Ecospace
  • Priority changed from NOT SET to low
  • Resolution set to fixed

In this particular case the issue was caused by the layer factory, which created missing visual styles. The default styles cause the database to be flagged as dirty.

This should not happen; defaults will always be re-created when missing and should thus not need saving. Only when the new default is modified should the dirty flag get set.

Fixed

Note: See TracTickets for help on using tickets.