Ticket #1508 (closed assessed: fixed)

Opened 20 months ago

Last modified 20 months ago

Toggling graph legends may not show all items

Reported by: jeroens Owned by: jeroens
Priority: normal Milestone: Ecopath 6: Release 6.5
Component: Overall GUI Version: 6.5 beta
Severity: minor Keywords:
Cc:

Description

On plots with multiple panes, such as Ecosim group plots, toggling "show legends" only shows legends on a few panels, not on all even though there is data

Change History

comment:1 Changed 20 months ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

The bug is caused by ZedGraph, that eliminates duplicate legend items across all plots. If a line with the same name occurs in multiple panels, the line is only shown in the legend for the first panel.

The graph needs to check for duplicate items per panel.

Fixed

Note: See TracTickets for help on using tickets.