Ticket #152 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Deleting groups from time series tab- jumps to another interface

Reported by: carieh Owned by: administrator
Priority: low Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

Once I have some data in the file (which was attached to a scenario when I loaded it) I am deleting individual groups time series- just for fun  When I delete a time series, the screen automatically jumps to the start screen. I cannot click and get into the time series tab right away, I have to go into another screen and then I can get back into the time series screen. Weird.
Oh wait- I can get directly from the start screen if I click the tab on the top, but not if I click the tree on the right- if I click the tree, I have to open another screen before the time series one.

I have tracked this down to Weifen Luo's dock panel, where this deletion somehow results in a WM_KILLFOCUS message to loose the active panel. It is NOT related to the messagebox that asks for delete confirmation. I'm at a loss at this moment what is causing this issue, but its severity does not warrant more time spent on it at this moment.

Change History

comment:1 Changed 11 years ago by administrator

related to #191

comment:2 Changed 11 years ago by carieh

Hey, this one was not resolved, but still having issues. If I create a new time series, and then delete it, I get the basic input screen. I can re-click back strait into the time series tab now, without hesitation.
Still- not the end of the world

comment:3 Changed 11 years ago by jeroens

Not a major issue at the moment, although a mistery that might lead to worse errors if not tended to

comment:4 Changed 11 years ago by jeroens

Hmm, it seems to have gone away with the forcing and time series display logic overhaul. I am not able to reproduce this. If you REALLY have time spare please check this again, but it's certainly no biggie!

Tested in the release after 6.0.3.10

comment:5 Changed 11 years ago by carieh

version 6.0.3.11
seems to be working fine now!

Note: See TracTickets for help on using tickets.