Ticket #154 (closed: unable to duplicate)

Opened 11 years ago

Last modified 11 years ago

Ecosim fails to save

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: crash Keywords:
Cc:

Description

Ok this one is kind of my fault, but still crashes the system...
If I am in a screen of Ecosim, and I try to load a scenario, I get this error message, and I have to shut down the program. Plus after I shut down the program my word document (still on the screen) flashes for a few seconds. I dont know I just thought it was funny. OS I guess you cannot access a new scenario of ecosim while any of the ecosim tabs are open.

Unable to duplicate on same model that Carie used? Let's keep an eye on this.

Change History

comment:1 Changed 11 years ago by carieh

Aug 19th
Using Jeroens 16 1/2 version

My idea of why this is happening...
If I try to create a new scenario while I am still in one, I get a pop-up message that asks if I want to save the first scenario. If I click yes, then it fails to save (or so the status bar says). I think this is going to be a problem with the program. It should be mentioned to the user that they need to exit all ecosim tabs before starting a new scenario, OR the program needs to recognize that if the user wants to create/ load a new scenario while already in ecosim, then they should be alerted/ warned to shut down all ecosim screens unless they can be automatically shut down for you (close all ecosim screens before starting a new scenario).

comment:2 Changed 11 years ago by jeroens

The problem here is that the scenario somehow fails to save. I am not sure why this is happening; I will need to see your database to be sure. I cannot reproduce this error on a newly imported model, and I can create a new Ecosim scenario with any number of windows open.

comment:3 Changed 11 years ago by jeroens

Oh! You write I get this error message. What does the message say?

comment:4 Changed 11 years ago by carieh

Oct 3
This is actually fixed for the most part (on its own). I can now create a new scenario while I already have one loaded. The only problem I have with this is that whatever screen I have open at the moment, will not reflect the changes automatically. I have to switch to another screen and when I come back it shows the new scenario

For example: I was using the forcing function tab when I loaded a new scenario, so I opened the biomass tab, ran the model, and then went back to the FF tab, which was now re-set. Also when I went to the biomass tab, the model flatlined (good as it was a blank scenario) so it reset itself here too.

Note: See TracTickets for help on using tickets.