Ticket #161 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Creating/ adding multistanza groups- cannot add more once created

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecopath Version:
Severity: minor Keywords:
Cc:

Description

Must add/create all multistanza groups at the same time or else changes do not show up. If you link 2 groups as multistanza, then close interface, reopen, add a third group as multistanza- only the first 2 show up. You have to delete all groups close interface and then re-open add all 3 in one go to make correct. It still works with the bug

Change History

comment:1 Changed 11 years ago by carieh

I think another way to get around the automatic updates is if you close all interfaces that you had open before you made the change, then re-open them. This seems to allow any additions/ deletions that you have made to appear.

comment:2 Changed 11 years ago by carieh

Ok I was wrong you have to close the model and re-open it.

comment:3 Changed 11 years ago by carieh

Also, if you mis-assign a group in the basic input interface, it is quite fussy to get it straight. For example, I accidentlly switched the juvenile and adult groups when I created groups, and now they are backwards. But I cannot just go into edit groups and swap them (move up or down). I can do this, but I have to re-assign age classes so that Ecopath understands where they go etc. This is not the end of the world, but it is not as easy to swap around as the single groups.

comment:4 Changed 11 years ago by jeroens

Solved a MAJOR headache that caused the GUI not to properly respond to stanza changes (in fact: model reloads). This made it seem that data changes did not get saved, although when reloading models these changes would suddenly appear as by magic. I cannot reproduce this bug anymore, please retest

Fixed in build 6.0.0.17

comment:5 Changed 11 years ago by carieh

Hey Jeroen still an issue here
I would suggest you open a model (any model) add in 3-4 groups and name them, assign them to the same multistanza group, and give ages. Then close the edit groups box and see where these groups come up. Mine seem to come up in the wrong order, as well as erasing a few groups that already existed. Plus they are not in the correct order, sometimes I get 2 of the same group I just created, and they are not assigned to multistanza correctly (sorry- I think this is the same bug)
If you go through these steps I think it will be clearer to you.

comment:6 Changed 11 years ago by jeroens

Unable to duplicate on both our ends. Let's not close this issue because there still seems to be a problem somewhere. Let's reactivate this bug report the moment we can reproduce the issue solidly

comment:7 Changed 10 years ago by jeroens

Unable to reproduce in the last year. Let's close this issue, no?

comment:8 Changed 10 years ago by carieh

can now add groups many times and add them to multistanza without errors

Note: See TracTickets for help on using tickets.