Ticket #165 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Ecopath unable to run with negative key index values

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description

Could be related to bug 165,
If I add an immigration value into the other production interface in ecopath, I should get a negative net migration in key indicies tab. BUT in reality this value goes missing. Model lab 1 aug 28.

4 oct 07: JS changed bug description. The interface accepts negative values but the core seems to have trouble dealing with these negative values

Change History

comment:1 Changed 11 years ago by administrator

related to #164

comment:2 Changed 11 years ago by carieh

If I enter in a biomass, P/B, and EE for a primary producer (so basically I have left no parameters for Ecopath to estimate, the pop-up screen asks if I want to estimate biomass accumulation (which I do) and I do get a negative rate in the key indices screen in this instance (lab 5 july 27). so it will estimate a negative value, but perhaps not directly from the other production screen.

comment:3 Changed 11 years ago by jeroens

The problem here is that by default cells with negative values are interpreted as 'having no value'. However, there is a range of variables that can be negative. There is a system in place to allow negative values, this just needs to be used for these specific variables. Therefore, this bug is related to most other 'does not display negative values' issues.

comment:4 Changed 11 years ago by carieh

Using the Lab 5 model, I re-tested this, and I cannot get the model to run (balance) with an immigration rate of anything other than 0.
The model will balance correctly, but when I add a value for the immigration, the model fails to run.

comment:5 Changed 11 years ago by joeb

Hi Carieh
As far as I can tell this is working now. I seem to be able to enter negative values into 'Other production' / 'Biom. accumul. (t/knm2/year)' then run Ecopath and get the same values as EwE5.

comment:6 Changed 11 years ago by carieh

re-tested lab 1 with a variety of values in the other production interface, and I can get both positive and negative values back out. Also I can enter in negative values for biomass accumulation rate and the output is the same as version 5.

Note: See TracTickets for help on using tickets.