Ticket #186 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Ecosim parameters > proportion of base nutrients not making changes to biomass output

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

Ok I am going off of what version 5 does when I change the parameters. In this case when I change the proportion of base nutrients, I do not get changes in the output as I would expect (or what version 5 is showing me). I suspect these changes are not making it to the output.

Change History

comment:1 Changed 11 years ago by carieh

Hi Joe,
Ok I just checked this interface (version 6.0.3.3) and there is an update that should make things clearer. Now when I go to the Input>ecosim parameters, I have a choice of forcing functions (which was not there before) so this is now clearer to the user what FF they are assigning to the nutrients. My Q's are
1- does this automatically apply the forcing function to the nutrients?
2-How do you tell these differences in the Run ecosim results?

Also there is a shape 0, which I believe does not exist. If this is meant to be a dummy (as in not assigning a FF to these groups, could we instead of having a 0 FF, have a blank tab or no nutrient loading FF applied so the user know ther is NOTHING applied, the 0 looks like it might actually be something , bot i dont think it is.

comment:2 Changed 11 years ago by carieh

Also I refer to biomass output which is actually the run ecosim tab (referring to the graphic results) as the interfaced was named differently when I recorded this bug

comment:3 Changed 11 years ago by carieh

To reproduce:
-load ecopath model and ecosim scenario (I used lab 5- scenario: lab6mediation)
-run ecosim
-go to Forcing function tab
-create a linear FF (remember the #)
-Go to Ecosim parameters
-assign the linear FF you just created to the nutrient loading function (the #'s can be confusing as they are now)
-re-run ecosim
-see difference in results
-compare to version 5

comment:4 Changed 11 years ago by joeh

Hi Carie
I run the latest code today and find that there is no longer a shape 0 item in the Nutrient Loading Forcing Function drop down list. Instead we have a none item. This means that in the next build (6.0.3.4+) you should be able to see those changes.

If you select a forcing function in the Ecosim Parameter tab and then click Run in the Ecosim Run tab, you should be able to see the effect of the forcing function on the biomass output curves. In fact, if you create and then apply a linear forcing function, the resulting biomass output curves also behave linearly.

comment:5 Changed 11 years ago by carieh

version 6.0.3.7
can now apply various forcing functions to the nutrient loading function, and they give consistent results to version 5

Note: See TracTickets for help on using tickets.