Ticket #191 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Deleting a newly added time series causes Tampa Bay model to crash

Reported by: robynf Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: crash Keywords:
Cc:

Description

Tampa Bay model freshly imported from old Ecopath database.
Added a new time series using the Values box on the Time series form
(Group = 0-12 Snook, a multistanza group; Absolute Biomass; weight = 1)
Clicked Remove
Unhandled exception index was outside the bounds of the array

Error DID NOT occur with Georgia Strait model, which already had time series read in. Deletion of imported and newly added timeseries was successful.

Change History

comment:1 Changed 11 years ago by administrator

related to #152

comment:2 Changed 11 years ago by jeroens

I resolved a crash on deleting the very last time series from a scenario. I am not able to reproduce any other crashes on the Tampa Bay model.

comment:3 Changed 11 years ago by carieh

Remove- works, but the screen changes back to the basic input screen instead of remaining on the time series screen. When you go back to the time series screen the time series has been removed, but I am not sure why it is jumping around?

comment:4 Changed 11 years ago by jeroens

The crash is solved. The jumping interface is already logged as bug 154.

comment:5 Changed 11 years ago by carieh

Ok no crashing, but model takes you back to the basic input screen.

comment:6 Changed 11 years ago by jeroens

Phew, crash is solved. The silly screen switch - which is still a mystery to me - is already logged under bug 154; I have closed this bug.

Note: See TracTickets for help on using tickets.