Ticket #196 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Notes/bugs with Monte Carlo form

Reported by: robynf Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

  1. Why does the Apply best fits button on the Monte Carlo form jump the user to the Fishing policy search form? (I now can't reproduce this one)


  1. Is the pedigree going to be implemented? If not, it shouldnt be on the Monte Carlo form.
  1. Changing the cv seems not to change the limits or the mean of the parameters
  1. After clicking Apply best fits and being jumped to the fihing policy search, when I returned to the MC form, the time series had been Unapplied and had to be re-applied before another run could take place. (I now can't reproduce this one).
  1. The Overlay button on the biomass plot tab seems to not work all the time (I had it working and now it seems to have stopped working). I think it has a slightly different functionality here than on the Biomass screen, in that it should overlay each trial (this is what it seemed to do once before but now doesnt). When I stopped a run and then hit run again, it started the trials again at 1 (ok) but, because the overlay button was on, it left the old results there (but didnt overlay onto them, they just stayed there). Perhaps the Stop button could clear the screen so that the Overlay command only overlays trials, not complete MC runs? (I now can't reproduce this one - it seems to be working perfectly now) (okay, I'm reproducing it again now - quite random; I just turn off show biomass and turned it back on again - maybe that affected it?) (oh, now I can't reproduce it again!)
  1. The Group selection on the left takes a long time to work the first time then takes a few seconds each time after that.
  1. When the MC form wasn't working properly (when Apply best fits jumped the user to the Policy form and unapplied the time series) I had othre problems with the time series, in that I could not unapply them on the time series form. I can't reproduce this now and it all works well.
  1. Is the cv that the users sets on one tab supposed to be applied to all tabs? Currently that is what happens.
  1. The Layers tab on the Biomass tab seems not to work.
  1. Another random error. The best fitting parameters tab is not being updated at the end of each run. It is the first time, then not any more. It seemed to be working okay earlier.
  1. Related to above random error: When the 'best fitting parameters' tab was being correctly updated, 'apply the best fitting parameters' did not work properly (i.e. the new resulting Ecopath parameters on the basic input form did not match those on the 'best fitting parameters' tab. Now the 'best fitting parameters' tab isn't being updated properly, the 'apply the best fitting parameters' is working perfectly!

Change History

comment:1 Changed 11 years ago by jeroens

De-assigned

comment:2 Changed 11 years ago by joeb

I think I've fixed all these issues
jb

Note: See TracTickets for help on using tickets.