Ticket #205 (closed assessed: not an issue)

Opened 11 years ago

Last modified 8 years ago

Apply Time Series overwrites original forcing function data

Reported by: jeroens Owned by: villyc
Priority: normal Milestone: Ecopath 6: release 6.0.8
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description (last modified by jeroens) (diff)

When applying Time Series of type 3 and 4, original Fishing Rate or Fish Mortality shape data will be overwritten by time series data. This has two malicious effects:

  1. If the user Saves the Ecosim scenario after applying such Time Series data, his/her original Fishing Rate or Fish Mortality values are lost
  2. Unapplying such Time Series will NOT restore the original Fishing Rate or Fish Mortality data; this data has been overwritten by the time series. Only reloading the Ecosim scenario will restore the fishing rate and mortality values.

This behaviour is by design, does it need changing?

Change History

comment:1 Changed 11 years ago by joeb

I think this behavior is the same as EwE5. I need to check this but if it's the same them there is no need to fix it at this time.

comment:2 Changed 8 years ago by shermanl

  • Status changed from new to closed
  • Resolution changed from open to not assessed
  • Description modified (diff)

comment:3 Changed 8 years ago by shermanl

  • Status changed from closed to reopened
  • Resolution not assessed deleted

comment:4 Changed 8 years ago by shermanl

  • Type set to not assessed
  • Description modified (diff)

comment:5 Changed 8 years ago by jeroens

  • Type changed from not assessed to assessed
  • Description modified (diff)

comment:6 Changed 8 years ago by jeroens

  • Owner changed from joeb to villyc
  • Status changed from reopened to assigned
  • Description modified (diff)
  • Milestone changed from Ecopath 6 to Ecopath 6 TODO

comment:7 Changed 8 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution set to not an issue

This behaviour is by design, inherited from EwE5

Note: See TracTickets for help on using tickets.