Ticket #212 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

FF duplicate button not working correctly

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description

I can create new FF's, but when I try to duplicate them, I get the correct heading duplicate of... but i get a flat line on the graph not a duplicate of what I just drew.

The first time I tried this, I did not save the changes I made to the model (which may have been the problem)
but the second time, when prompted, I did save the changes to the model- I get a pop up asking if I want to save the model, and i do but the new shape goes to a flatline, and the shape I just created goes to a flat line.

I have also tried saving the model manually before trying this, and saving the scenario manually, but neither of these work.

Change History

comment:1 Changed 11 years ago by user8

Hi Jeroen,

I kind of fixed it from UI, it is caused by calling CreateNewSHape instead of duplicating it. So it works at the first time, but then next time ShapeToolBox? was being reloaded, the ShapeManager? seems to reset it to the default shape, and also by answering No to save scenario, could you check DB end and Core end for this issue?

Thx..
Fang

comment:2 Changed 11 years ago by jeroens

I do not know whom to credit for it, but it seems to work correctly now. My best bet is that this got solved with a minor correction to the ecosim save logic.

comment:3 Changed 11 years ago by jeroens

Ok, Fang fixed this, whoohooo! The database is sound

comment:4 Changed 10 years ago by carieh

I can duplicate the FF now, although it is quite slow on the computer (it almost freezes and then comes to again). This could be due to the fact that there are 369 default FF axis (version 6.0.3.14). So basically this is working, although it is very slow and almost makes the computer freeze

comment:5 Changed 10 years ago by jeroens

Bounce

Note: See TracTickets for help on using tickets.