Ticket #215 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Ecosim FF values- not saving changes

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

If you create a new FF and go to values instead of drawing, and type in values, you cannot save the values. There is an error message that appears index was outside the bounds of array (see message below).
Even if you click continue, the values do not change the sketch.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

Exception Text
System.IndexOutOfRangeException?: Index was outside the bounds of the array.

at SourceGrid2.Grid.get_Item(Int32 row, Int32 col)
at ScientificInterface?.Ecosim.frmShapeValue.OnApplyForcing?()
at ScientificInterface?.Ecosim.frmShapeValue.OK_Button_Click(Object sender, EventArgs? e)
at System.Windows.Forms.Control.OnClick?(EventArgs? e)
at System.Windows.Forms.Button.OnClick?(EventArgs? e)
at System.Windows.Forms.Button.OnMouseUp?(MouseEventArgs? mevent)
at System.Windows.Forms.Control.WmMouseUp?(Message& m, MouseButtons? button, Int32 clicks)
at System.Windows.Forms.Control.WndProc?(Message& m)
at System.Windows.Forms.ButtonBase?.WndProc?(Message& m)
at System.Windows.Forms.Button.WndProc?(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow?.OnMessage?(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow?.WndProc?(Message& m)
at System.Windows.Forms.NativeWindow?.Callback(IntPtr? hWnd, Int32 msg, IntPtr? wparam, IntPtr? lparam)

Loaded Assemblies
mscorlib

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll


EwE6

Assembly Version: 6.0.0.20
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/EwE6.exe


System.Windows.Forms

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


System

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll


System.Drawing

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll


WeifenLuo?.WinFormsUI.Docking

Assembly Version: 2.1.2734.23473
Win32 Version: 2.1.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/WeifenLuo.WinFormsUI.Docking.DLL


EwEPlugin

Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/EwEPlugin.DLL


EwEUtils

Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/EwEUtils.DLL


EwECore

Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/EwECore.DLL


SAUPUtil

Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/SAUPUtil.DLL


Microsoft.VisualBasic?

Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.42 (RTM.050727-4200)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll


System.Configuration

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll


System.Xml

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll


System.Data

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll


EwECustomPlugins

Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/EwECustomPlugins.DLL


EwENetworkAnalysis

Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/EwENetworkAnalysis.DLL


SourceGrid2

Assembly Version: 2.0.3.1
Win32 Version: 2.0.3.1
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/SourceGrid2.DLL


SourceLibrary?

Assembly Version: 1.2.0.0
Win32 Version: 1.2.0.0
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/SourceLibrary.DLL


ZedGraph?

Assembly Version: 5.0.8.21916
Win32 Version: 5.0.8.21916
CodeBase?: file:///C:/Program%20Files/Ecopath%20with%20Ecosim%206.20/ZedGraph.DLL


System.Transactions

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_32/System.Transactions/2.0.0.0__b77a5c561934e089/System.Transactions.dll


System.EnterpriseServices?

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_32/System.EnterpriseServices/2.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll


bzh6rxry

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll


System.Deployment

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.832 (QFE.050727-8300)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll


Accessibility

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase?: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll


JIT Debugging
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>

<system.windows.forms jitDebugging=true />

</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Change History

comment:1 Changed 11 years ago by administrator

duplicate of #206

comment:2 Changed 11 years ago by carieh

Same as bug 206 reported by Robyn- sorry for the duplicate

comment:3 Changed 11 years ago by user8

Crash was gone.. But as described in other bugs, SketchPad? and thumbnail don't get updated correctly.

--- F

Note: See TracTickets for help on using tickets.