Ticket #258 (closed: suspended)

Opened 11 years ago

Last modified 9 years ago

Logging application events in the Log file seriously affects application performance

Reported by: jeroens Owned by:
Priority: low Milestone: Ecopath 6: build 6.0.7
Component: Overall Logistics Version:
Severity: major Keywords:
Cc:

Description (last modified by jeroens) (diff)

Currently, application events are logged in an XML file which is opened, appended to and closed again after every event, which seriously affects application performance when the log file reaches a size > 1MB.

I propose to use a flat text file that simply can be appended to. Additionally, the text file can be kept open while the application is running. This is not possible with XML based files.

This will still give us good information content but with serious performance gain.

Change History

comment:1 Changed 11 years ago by administrator

related to #219

comment:2 Changed 11 years ago by jeroens

Temporary fix: only important messages are logged. Next, the file could be changed from XML to flat text format

comment:3 Changed 11 years ago by jeroens

A few modifications have made to the log file a few months ago, such as logging less events (only log warnings and errors, not normal maintenance and information events) and opening a log file per model rather than one log file for all models.
Performance does not seem to be affected negatively any longer. The issue is therefore acknowledged and unassigned, but not closed in case this becomes an issue.

comment:4 Changed 9 years ago by jeroens

  • Status changed from new to closed
  • Resolution changed from open to suspended
  • Description modified (diff)
Note: See TracTickets for help on using tickets.