Ticket #278 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Changing group colours fails to change group colours in Ecosim plot

Reported by: joeb Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Overall GUI Version:
Severity: minor Keywords:
Cc:

Description

Open any model. Goto 'Tools/Options? select the 'Model/Color?' node and change the groups colours via 'Use defaults' or 'Use scale' select 'Ok', this should save the changes. Open the Ecosim biomass plot and run the model to display the group colours. Some colours will have changed but not all. Sometimes saving the model at this point causes a crash, although not with all models.

Change History

comment:1 Changed 11 years ago by administrator

related to #376
duplicate of #159

comment:2 Changed 11 years ago by joeb

Also when group colours are changed the core thinks that Ecopath data has changed and Ecopath needs to re-run before ecosim can be run. If the Ecosim interface is up, which it most likely as you would not be changing the colors with out seeing them first, this forces the status panel to resize the main form which causes the graph to draw twice. If the model is big this is a disaster, the whole interface appears to stall and flash and stutter on the multiple draws.

comment:3 Changed 11 years ago by jeroens

Solved

comment:4 Changed 11 years ago by jeroens

..in build 6.0.3.2

comment:5 Changed 11 years ago by carieh

My version 6.0.0.3 freezes when I make these changes. If I change the colors while the run ecosim interface is open, the colors change on the plot that has just been run. However, all of the buttons become grey (so you cannot click them). If you click on another screen and then back to the run ecosim interface the run (and other) buttons become usable again. Then you can run. The first time I tried this I got an error that crashed the program. The second time it ran fine.

comment:6 Changed 11 years ago by jeroens

The buttons become gray for a reason: something in Ecopath has changed (the colours) which causes the application to disable any Ecosim ouput forms until Ecopath has run again. This is why opening up another screen re-enables the Run Ecosim interface: if you check the status panel you'll see that Ecopath has just ran again.

I'm not sure about the crash; I need to see specific info 'cause I'm not able to reproduce.

For the rest the colour behaviour is consistent with the way we designed it. Maybe it's not proper; we should for instance consider running Ecopath again whenever an already open Ecosim form is reactivated, but that is too much work at this stage.

comment:7 Changed 11 years ago by joeb

Nov 20, 2007 This seems to be broken again

comment:8 Changed 11 years ago by jeroens

Fixed after build 6.0.3.5

comment:9 Changed 11 years ago by carieh

Version 6.0.3.6
There are no crashes, and color change happens automatically.
If you have Run Ecosim interface open while you make color changes, you cannot re-run. you have to close the interface and re-open to run again.

This happened in the tampa bay model, but in the Ocean test model I did NOT have to close and re-open the run Ecosim interface. I am not sure what the difference in these 2 models is?
_Lab 6 model with Ecosim scenario lab-cod: I also had to close the interface in this model before I could re-run. Sorry I am not sure why some are working and some are not

comment:10 Changed 11 years ago by jeroens

The original bug has been resolved. What you reported now is a duplicate of bug 290. Thanks!

comment:11 Changed 11 years ago by carieh

I think this is the same as bug 378 I reported, but maybe a slightly different issue. Basically they are both problems with the coloring.

comment:12 Changed 10 years ago by jeroens

Resolved after build 6.0.3.13

Note: See TracTickets for help on using tickets.