Ticket #287 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Update issue when clicking tabs (works for tree node)

Reported by: shermanl Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Overall GUI Version:
Severity: minor Keywords:
Cc:

Description

When Ecosim is loaded, you change a basic input value, go back to Run Ecosim using tabs, you will see it disabled.

Tabs and forms do not know about what state they are in. So when you enable it, it does not know how to run the state machine to the correct point, i.e. EcosimHasRun?

Change History

comment:1 Changed 11 years ago by jeroens

This is by design, at least as currently implemented. Activating an existing page does not trigger the core controller to bring the core back into the state that the form requires.

We should find the best solution in a meeting; I'm not sure if I want tabs to trigger the core controller.

comment:2 Changed 10 years ago by jeroens

Ok, forget about that last note. I tracked down the problem: Weifen Luo's Docking panel suite does not fire off any events when the user switches pages using Ctrl+Tab. It *could* be fixed by trapping an Activation / GetFocus? event in the form itself, this needs to be explored

comment:3 Changed 10 years ago by jeroens

Is't even getting better - the tab page activated via Ctrl+Tab causes a tab page event that is ONE SWITCH behind the current tab. Nice!

comment:4 Changed 10 years ago by jeroens

Unable to fix at this moment - not enough time. The issue is known. Best resolution would be to upgrade to a newer version of the dockpanel. We are using version 2.1, version 2.2 has been downloaded and is stored in CVS.

comment:5 Changed 10 years ago by jeroens

Hmm, I installed DockPanel? suite 2.2 and the bug persists. It will require some zealous debugging of the code itself. Let's not fix this for now.

comment:6 Changed 10 years ago by jeroens

I managed to solve this by digging into the DockPanel? code. Fixed after build 6.0.3.20

Note: See TracTickets for help on using tickets.