Ticket #290 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Apply Egg production> assigning groups does not save

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

When I apply Egg production, it seems fine model does not crash. But if I apply to a group (krill in Antarctic model) save the model, close and re-open, the shape is no longer assigned to the multi-stanza group. The shape, and name I have created are saved properly, but there is no egg shape assigned to the group.

Change History

comment:1 Changed 11 years ago by jeroens

Ooh, this one's yummy. Fixed two bugs:

comment:2 Changed 11 years ago by jeroens

Fixed in build 6.0.3.2

comment:3 Changed 11 years ago by carieh

Version 6.0.0.3
I am still not keeping the shape assigned to the multi-stanza group. To re-create:
-open Tampa Bay model
-go to egg production
-create a few shapes
-assign them to various multistanza groups
-close model (save when prompted)
-re-open model
-go back to egg production/apply egg production
-groups will not have shape assigned

On another note: when I re-name the Egg shapes, and close the model (click yes to save) I get a warning box. The names do save correctly, but I am not sure the warning. To re-create:
-go to eff production
-re-name a few shapes
-close model (click yes to save)
-you should see error message
-when you re-open names should be saved correctly

comment:4 Changed 11 years ago by jeroens

Made some improvements to the ApplyFF form which will appear after build 6.0.3.3. I was however not able to reproduce the error anymore.

The name change issue is logged as a new bug - more dirt got dislodged.

comment:5 Changed 10 years ago by carieh

version 6.0.3.11
names stick and it does apply to group

Note: See TracTickets for help on using tickets.