Ticket #296 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Multistanza group ordering

Reported by: villyc Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Overall GUI Version:
Severity: minor Keywords:
Cc:

Description

I had a multistanza with two stanza's: group 3 and group 44. The + - ti show/hide the group under the multistanza will only hide group 3 when pressing it, not group 44.

Change History

comment:1 Changed 11 years ago by jeroens

I need to see the database once this bug is reproduced

comment:2 Changed 11 years ago by jeroens

Fixed after build 6.0.3.4

comment:3 Changed 11 years ago by jeroens

To reproduce: in EditGroups?, assign a few groups to a stanza configuration but make sure the life stages are not in consecutive rows. For instance assign group 1, 5 and 8 to a stanza configuration and do not move the rows together.

Now, when toggling the stanza visibility icon [+]/[-], not all stanza life stages are properly hidden/displayed.

I can think of two solutions:

  1. Prompt the user to sort the life stages / add sort option on EditGroups? form / Automatically sort the life stages (not so much work and probably the proper way to go)
  2. Make the form smarter to deal with unordered stanza (that's a lot of work because this logic has to be applied to other forms as well)

comment:4 Changed 11 years ago by jeroens

I implemented a fix where all rows belonging to a stanza configuration are now hidden or displayed, regardless whether the rows are ordered. Implemented after 6.0.3.7

comment:5 Changed 11 years ago by carieh

version 6.0.3.11
can alter where the MS groups are and still hide

Note: See TracTickets for help on using tickets.