Ticket #322 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Mediation/Forcing Function shapes not available

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

Version 6.0.3.4
I cannot get access to any of the shapes in this build. I get an error message, when I click continue shapes do not show up
To reproduce:
-open model
-go to mediation (or forcing function)
-click options> shapes
-try to select any of the shapes

Change History

comment:1 Changed 11 years ago by administrator

related to #335
related to #386

comment:2 Changed 11 years ago by jeroens

Solved after build 6.0.3.5

Note that the the sketchpad options dialog has been split in two:

  • Options dialog now serves the sole purpose to change shape display options
  • A new dialog 'Change shape' is added to change the contour of a selected FF/EggProd/MedFn to a common shape

comment:3 Changed 11 years ago by carieh

Ok there are 2 issues still occurring:
1- linear shape is working (version 6.0.3.6), but in order to get the shape to occur you have to select the shape and then click on the graph somewhere before it will change, so it is not automatically updating

2- all other shapes are not being displayed correctly. Some alter the graph, but not in consistent ways so that I can identify what shape they are trying to be.

comment:4 Changed 11 years ago by jeroens

1- Mediation update issue solved with #390
2- All types of shapes should now work well with Mediation

comment:5 Changed 10 years ago by carieh

version 6.0.3.11
still haing issues creating shapes (other than linear) Please see comments for bug 390- they are the same

comment:6 Changed 10 years ago by jeroens

Hmm, it seems to be really ok now? Behaviour identical to EwE5. It's clumsy but hey, it works. Ideally this should have a graphical interface where users can drag curve points and directions (similar to Photoshop's colour profile editors)

comment:7 Changed 10 years ago by carieh

Almost there
They all work except for exponential (no graph appears)
All of the rest look very nice
Version 6.0.3.18

comment:8 Changed 10 years ago by jeroens

Carie, this is not true (build 6.0.3.18+)
You just need to provide a positive value for Y zero.

Note: See TracTickets for help on using tickets.