Ticket #344 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Seasonal forcing function imported as longterm pattern

Reported by: cathyb Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description

The only seasonal forcing function pattern imported (1 of the 2) was displayed as a longterm pattern with the scale consistent with the long term pattern scale rather than seasonal monthly scale.

The tab in the menu bar where you choose seasonal or longterm is set to longterm despite the title saying that it is seasonal shape 1. If you choose to change it to seasonal it says that is will override the data.

Change History

comment:1 Changed 11 years ago by jeroens

This issue is minor since the seasonal flag is predominantly used for display only. Will fix soon.

comment:2 Changed 11 years ago by jeroens

Hmm, unable to reproduce in build 6.0.3.6 but this may have been fixed with the recent FF import changes. If not, I would like to see Cathy's original EwE5 database to see what is really happening.

comment:3 Changed 11 years ago by carieh

Ok I think I can reproduce the issue. This has to do with importing FF from version 5. To recreate I went to version 5
-opened lab 5 model
-created a new ecosim scenario
-created 1 seasonal FF and 1 long term FF (saved them both)
-Imported the model into version 6 (6.0.3.6)
-opened the FF and they were NOT CORRECT
well the long term one was the same, but the seasonal model was not the same shape as before. Also I ran the model in Ecosim to see if the values in the FF were off or just the image, but it seems as though the values being imported are not correct.
-the imported seasonal model does appear to be seasonal in my model though, but there are still issues with the importing.

comment:4 Changed 10 years ago by jeroens

The seasonal flag is imported correctly, as is the shape data itself. However, in EwE5 shapes could be drawn by hand over all Ecosim years but still be flagged as seasonal, which is not correct. EwE6 will import all data for these shapes, and will import the seasonal flag correctly. However, only the first twelve values of the shape will be shown (due to the seasonal flag being active)

If you now toggle the seasonal flag to long-term, the entire shape will become visible.

This behaviour is by design. All data is correctly imported. The seasonal flag is merely a display setting now.

Tested well after 6.0.3.14.

comment:5 Changed 10 years ago by carieh

version 6.0.3.18
Jeroen, I think we have made it so that all forcing functions are imported as long term, even if they are seasonal FF in version 5? Is this correct?
I have imported a seasonal forcing function and it imports as long term. When I switch it to seasonal then the FF reverts to a flat line (default values: looks the same as when you hit reset)

comment:6 Changed 10 years ago by jeroens

Yes, you are right. There was never any distinction in the data between seasonal and long-term shapes - even in 5!

Note: See TracTickets for help on using tickets.