Ticket #345 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Ecosim Biomass not the same from EwE5 to EwE6

Reported by: shermanl Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

From Kelly Kearney: kkearney@…

Sherman,

I'm having some trouble making sense of some of the results I'm seeing when running what is supposedly the same model through different versions of EwE. I think the difference might be due to the effort scenarios being used, but I'm having a hard time figuring out exactly what effort data each one is using.

In EwE 5, all the effort input miraculously appeared in the specific scenarios I was using. The FAO 67 model that I am working with had already been set up with 7 effort datasets, which I assume had been loaded from a timeseries file at some previous point in the model setup. However, when I imported the model to EwE 6, the Time series section now holds a ton of datasets. There are two whose names seem to correspond to the version 5 effort timeseries, but visually do not really resemble the previous series.

So, specific questions...

1) Is there a way to export the effort data from both EwE 5 and EwE 6? Both have the little Values button, where you can view a single dataset. Is there a less tedious way to get at all the numbers, other than copying each one individually?

2) I always assumed in the old version that effort data was submitted by fleet, and then the Ecopath input data on fishery landings was used to translate that into a specific loss to each group. Is this correct?

-Kelly

==========================================
==========================================
Second email:

Huh, what? I found a bug? Where?

Well, I'm using both version 6.0.3.1 and 5.1.147. My interest is more in the underlying algorithms than in either interface, so I switch back and forth depending on which lets me investigate a given parameter more easily. For most, the new version 6 interface is preferable. But for effort, I find the new one very confusing. Or maybe it's the old one that I'm misinterpreting. Either way, they don't match.

Okay, I guess I'll have to clarify how I came to my conclusions. Really, this was just the result of mini-experiment number 5 billion to check if my rewrite was performing the same (or at least close enough, based on some intentional simplifications I've made) as the original EwE. The plan was to run the fitting 67 scenario, which had been parameterized to match several biomass and catch time series as closely as possible: once with the original EwE gui and once with my new code. In order to do that I needed to figure out what F values (the time-dependent fishing rate) were being used in the original scenario so I could force my model the same way. I figured the first step to doing this would be to decipher the Fishing rate (relative) data that gets plotted so prettily but with so little explanation beneath the relative biomass trends when Ecosim is run. The documentation defines the time-dependent fishing rate as follows:

F = (f * QR)/(1 + (QR - 1)*B_t/B_0),

where f = fishing effort, QR = qmax/q, B_t = biomass at time t, and B_0 = initial biomass. I guessed that this variable might be the same as what is plotted (which would be nice because then I'd have something to verify my numbers against). In my version of the model, I know all of the right-hand variables in that equation except f, so I set about trying to extract the input fishing effort data.

And then I realized that I have no clue what goes on behind the scenes as far as how effort data is inputed to the model, and how it is broken down between gears and functional groups. And then I realized that I couldn't even replicate the fitting 67 scenario in the new version of EwE versus the old one. And then I got really confused, and emailed you. :-)

As I mentioned, the effort data in the version 5 model that I have is simply a part of the saved Ecosim scenario fitting 67; I have no idea really how it got there. So my interpretation of how effort data is input and parsed is really just a guess... I guessed that someone fed it a time series with effort data by fleet, and the program broke that down based on the Ecopath definitions of gear landings per functional group. Seems I guessed wrong. :-)

I'm attaching the two models I'm working with, both old (FAO 67 1.MDB, model FAO 67, ecosim scenario fitting 67) and new (EwE6_FAO_67.mdb, ecosim scenario fitting 67). I would like to see the same results in the new version as you get when simply starting up the old version and running with no modifications.

Thanks,
Kelly

P.S. Plugins aren't really an option for me (even assuming I took the time to learn VB .net), since I don't have a copy of the new source code to tinker around with. I access one of your computers via remote desktop when I really need to look at the code (i.e. when I'm in a really masochistic mood), but I don't trust myself to play around with that copy.

Sherman Lai wrote:

Kelly,

Thanks for your bug report. Could you do me a favor and check what version (Help:About EwE6) of EwE6 you have. An older version did exactly the same misconception you did in question 2 below. We initially suspected the effort are listed by fleets, that is not the case because one is not able to separate the individual groups per fleet. They are submitted by group ID and this should be the case for both current versions. You can get the latest version here: ftp://ftp.fisheries.ubc.ca/ecopath/webfiles/ewe6/

Also, do you want direct access to this bug report to send these potential bugs? Sending to me works too. As for your questions:

1) Is there a way to export the effort data from both EwE 5 and EwE 6? Both have the little Values button, where you can view a single dataset. Is there a less tedious way to get at all the numbers, other than copying each one individually?

No, there is no automatic function that I know off that would do this. A plugin could easily be written in 6 to do this.

2) I always assumed in the old version that effort data was submitted by fleet, and then the Ecopath input data on fishery landings was used to translate that into a specific loss to each group. Is this correct?

See first paragraph.

Could you try this with the new version and let me know if this bug still exist.
Cheers,
Sherman

Kelly Kearney wrote:

Sherman,

I'm having some trouble making sense of some of the results I'm seeing when running what is supposedly the same model through different versions of EwE. I think the difference might be due to the effort scenarios being used, but I'm having a hard time figuring out exactly what effort data each one is using.

In EwE 5, all the effort input miraculously appeared in the specific scenarios I was using. The FAO 67 model that I am working with had already been set up with 7 effort datasets, which I assume had been loaded from a timeseries file at some previous point in the model setup. However, when I imported the model to EwE 6, the Time series section now holds a ton of datasets. There are two whose names seem to correspond to the version 5 effort timeseries, but visually do not really resemble the previous series.

So, specific questions...

1) Is there a way to export the effort data from both EwE 5 and EwE 6? Both have the little Values button, where you can view a single dataset. Is there a less tedious way to get at all the numbers, other than copying each one individually?

2) I always assumed in the old version that effort data was submitted by fleet, and then the Ecopath input data on fishery landings was used to translate that into a specific loss to each group. Is this correct?

-Kelly

--
Kelly Kearney
Princeton University
Department of Geosciences
Guyot Hall M70
Sayre Hall 304A
Princeton, NJ 08544

==========================================
==========================================
Third email

I've updated, but am still seeing the differences. The effort data is now automatically applied invisible to the user, as in EwE5. But exactly what is applied is still unknown, and based on the little red sketch plots, I think that may be the cause of the differences. Of the 7 gear types, only 3 (small pelagics, sealing, whaling) match between the two versions; the rest are obviously different. I've attached a screenshot that shows this. Both of these runs were done by simply loading the files that I sent you previously and hitting Run.

-Kelly

Change History

comment:1 Changed 11 years ago by shermanl

Issue 2 was fixed earlier. The second one will be reported as an nice to have feature.

Note: See TracTickets for help on using tickets.