Ticket #346 (closed: fixed)

Opened 11 years ago

Last modified 11 years ago

Deleting/Unloading Time series leads to Out of bounds error in Run Ecosim

Reported by: shermanl Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: major Keywords:
Cc:

Description

Add and Apply TS,
Run Ecosim
Remote/Unload? the TS
Run Ecosim
Error message: Ecosim Run() Error: Index Out of bounds of the array.

Change History

comment:1 Changed 11 years ago by joeb

This is exploding in EcosimOutputLineGraph?.DrawLabels? m_sMaxYAxis = 0 which causes a divide by zero error. I have no idea why or how m_sMaxYAxis got set to zero but that's a good place to start.

comment:2 Changed 11 years ago by jeroens

Unable to reproduce in build 6.0.3.6. Joe mentioned that he might have fixed it; I believe it is.

comment:3 Changed 11 years ago by carieh

Hi, I followed the steps from Sherman and got the same result in version 6.0.3.6
I was using the lab 3 model- Ecosim scenario 10 year.
When I imported the model the time series needed to be imported. once I applied I ran the model.
-if you then un-apply the time series and run ecosim the model will run flat (as it should)
-if you REMOVE the time series ( I removed all of them)and then go to run ecosim you get the warning index bounds out of array or something to that extent. and Ecosim will not run

comment:4 Changed 11 years ago by jeroens

Tested in 6.0.3.13 and the issue no longer exists

Note: See TracTickets for help on using tickets.