Ticket #348 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Duplicate a forcing shape flags the Ecosim scenario as changed

Reported by: jeroens Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: tweak Keywords:
Cc:

Description

To reproduce:

  • Go to Ecosim > Forcing (or EggProd?, Mediation)
  • Click duplicate

(A save prompt may appear. Click 'Yes' to make sure scenario is saved)
The shape gets duplicated but the scenario is flagged as changed.

This is annoying; if a user wants to duplicate several shapes the scenario needs to be saved between every step. Instead, shape duplication should be an atomic action that does not trigger the scenario to become dirty.

Change History

comment:1 Changed 11 years ago by jeroens

Solution: pass ShapeData? as parameter into CreateNewShape? method

comment:2 Changed 11 years ago by jeroens

Resolved after build 6.0.3.6

comment:3 Changed 11 years ago by carieh

Hey Jeroen. In version 6.0.3.7 these changes (to egg production in this case) get saved automatically into the scenario. I am not sure if this was the intention or not. If yes the bug is fixed

comment:4 Changed 11 years ago by jeroens

Yes, that was the intention. Now the scenario is no longer flagged as dirty when the duplication is done.

comment:5 Changed 11 years ago by carieh

Version 6.0.3.8 in egg production shapes, you still have to save between every duplicate

comment:6 Changed 11 years ago by jeroens

Now really *really* fixed after build 6.0.3.10

I also changed the way new shape names are created. When a shape was copied too many times, and it's name contained too may 'copy of copy' iterations, the name would be rejected by the database.

comment:7 Changed 10 years ago by carieh

You still need to save between every step (version 6.0.3.11)
I added 5 shapes, and was prompted between every shape to save, I clicked yes but the model is still flagged as dirty I believe: In the lower right hand corner the model reads modified ( I believe that is dirty).

Personally I dont think it is a huge hassle, but you do still have to save between steps.

comment:8 Changed 10 years ago by jeroens

I cannot reproduce the issue in build 6.0.3.12:

  • Import new Georgia Strait model
  • Load a Sim scenario
  • Go to Egg Prod page
  • Add a shape (do not modify)
  • Click duplicate 4 times (no save prompts)
  • Close and reload the model, scenario and shapes are there (all flat-lined)

or

  • Load a Sim scenario
  • Go to Egg Prod page
  • Modify a shape
  • Save the scenario
  • Click duplicate 4 times (no save prompts)
  • Close and reload the model, scenario and shapes are there

I think this one's done

Note: See TracTickets for help on using tickets.