Ticket #355 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Ecosim not clearing memory?

Reported by: robynf Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: major Keywords:
Cc:

Description

Some funny stuff going on with Ecosim.

  1. Georgia Strait model.

a.I switched off all forcing functions, biomass accumulation - this should cause the model to flatline but does not.
b.I cannot reset Fs because buttons don't work - see separate bug.

  1. I switch on fleet dynamics (on ecosim parameters tab) - it changes the biomass trajectories as expected
  2. I switch off fleet dynamics
  3. Run Ecosim gives me no change in biomass trajectories
  4. I perturb the fishing effort with the sketch pad - it changes the biomass trajectories
  5. But I cannot reset them
  6. NOTE THAT THE MODEL HAD A BIOMASS ACCUMULATION ON DOLPHINS WHEN I OPENED IT. SWITCHING THIS BIOMASS ACCUMULATION ON AND OFF DOES NOT AFFECT THE BIOMASS TRAJECTORIES WHICH IT SHOULD.
  1. Tampa Bay model

a.I turn off biomass accumulation and all forcing functions

  1. as far as I can tell, there is no time series loaded - nothing shows up on the time series form
  2. I Run Ecosim and there are huge annual changes for all groups - where is this coming from?
  3. I can change the biomass trajectories by switching on fleet dynamics but cannot change them after this - even after switching off fleet dynamics
  4. the only way I can get the biomass trajectories to change is by using the sketch pad
  5. It looks to me like there has to be residual forcing of some kind in there, even after I have switched everything off. Are there time series in the database that the user cannot access?


Change History

comment:1 Changed 11 years ago by joeb

The variation in Ecosim output in both Georgia Strait and Tampa Bay are caused by a Nutrient force function in the EcoSim? parameters form.

joe

comment:2 Changed 11 years ago by carieh

Version 6.0.3.14
I am using Georgia Strait model again and I am still having problems trying to get the model to flatline in ecosim. I opened the existing ecosim model all fit, and removed all forcing functions, nutrient functions, set vulnerabilities back to the default of 2, and removed the biomass accumulation. The model gets close to flatlining, but it is still not there.

So I created a new scenario with all the defaults built in, and this scenario does not flatline either. There is no FF or nutrient forcing of any kind, not biomass accumulation, etc. I am not sure what the problem is...and I re-set the default fishing efforts on both scenarios. Hmmmmm???

comment:3 Changed 10 years ago by joeb

The Georgia Strait model will flat line for me????
joe

comment:4 Changed 10 years ago by carieh

Sorry Joe... I am still not flatlining in EITHER of these models. I am in version 6.0.4 using the databases that come with this version.
If you go into ecopath, turn off all biomass accumulation, create a new scenario, set default vulnerabilities=2, NO time series, No FF, No nutrient input, base proportion of nutrients=1, all the default values.....Still not flatlining for either model

Also when I go into the existing scenario and try to delete off things like biomass accumulation etc. I cannot get the model to flatline.....Sorry

comment:5 Changed 10 years ago by joeb

Hi
There have been some changes that may have caused this that have been fixed it in the version that I'm using 6.0.4.6 anyway both these models flatline for me. Something to watch out for here is the scale of the graph.

Note: See TracTickets for help on using tickets.