Ticket #370 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Multistanza orgVBK problem

Reported by: villyc Owned by: administrator
Priority: high Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: crash Keywords:
Cc:

Description

c.core calculatestanza

Got an error from the code below as orgVBK was 0. Had deleted, saved, then re-introduced stanza groups causing trouble (the trouble that Jeroen looked at recently)

Should have a trap to make sure that orgVBK gets a value if there's none, e.g, 0.3 which I think should be the default. Currently the default is -1, which doesn't allow calculations????

If SecondAge?(nStanzas) = 0 Then

For i = 2 To nStanzas

SecondAge?(i - 1) = FirstAge?(i) - 1

Next
SecondAge?(nStanzas) = CInt(Math.Log(1 - 0.9 (1 / 3)) / (-orgVBK / 12))
If SecondAge?(nStanzas) > 400 Then SecondAge?(nStanzas) = 400

End If

I decided to delete all references to the stanza group in the ecopath group definition, but subsequently got an error in cecosim splitinitialize where m_stanza.Nsplit hadn't be reset to 0 after the deletion

I just can't get around this, and get the model to work.

Villy

Jeroen has looked at this earlier, but still problems

Change History

comment:1 Changed 11 years ago by jeroens

The problem is caused by Stanza configurations without life stages. These configurations cannot be removed via the UI. I've added a database check to prevent such groups from being read into the system. I am just not sure how these groups are getting created; this needs to be figured out.

comment:2 Changed 11 years ago by jeroens

Database fix in place after build 6.0.3.7

comment:3 Changed 11 years ago by carieh

Ok I am not fully understanding this one. I think the bug is that the defaults on the edit multistanza groups is incorrect. The value is a -1 instead of a more logical default like 0.3.
In version 6.0.3.11 the default is still -1. If I am interpreting this incorrectly, please send more information. thanks

comment:4 Changed 11 years ago by jeroens

-1 is not good. Now changed to 0.3 by default when a group is assigned to a stanza config, and changed to -1 when removed from a stanza config.

Fixed after build 6.0.3.11

comment:5 Changed 10 years ago by carieh

version 6.0.3.14
the default for vonB growth in the multi-stanza interface is now 0.3 ..all better

Note: See TracTickets for help on using tickets.