Ticket #390 (closed: fixed)

Opened 11 years ago

Last modified 10 years ago

Cannot remove Egg production

Reported by: shermanl Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

Load TS (Grouper.mdb)
Create new Egg production
Apply egg production

Run Ecosim and see cycles.

Now remove egg production... good luck coz there is not feature for this.

Change History

comment:1 Changed 11 years ago by jeroens

Oh, I knew this would come back to bite us... the M$ Access driver has no solid way to set foreign keys to NULL. The Egg shape database ID was still in use, hence the database integrity rules refused to delete the shape.

The same bug occurred when deleting Stanza-based hatch code shapes, and salinity forcing shapes and nutrient forcing shapes for Ecosim scenarios.

The solution is to manually NULL the links to these shapes in the database engine. Solved after build 6.0.3.10

comment:2 Changed 11 years ago by carieh

version 6.0.3.11
I created an egg shape
-applied to multistanza groups
-ran model
-removed link (selected blank tab in apply egg production interface)
-ran ecosim

the egg production is still on even though I removed the link, it is still applying it to the model

comment:3 Changed 10 years ago by jeroens

Build 6.0.3.13: unable to reproduce.
This was probably fixed along with other recent Apply EggProd? changes.

Tested:
Run Sim - Note state 1
Apply Eggprod
Run Sim - Note state 2, which should differ from state 1
Un-apply eggprod
Run Sim - Note state 3, which is identical to state 1, and differs from state 2

comment:4 Changed 10 years ago by carieh

Woo-hoo
Now egg production turns on and off!!
Version 6.0.3.18

Note: See TracTickets for help on using tickets.