Ticket #432 (closed: fixed)

Opened 10 years ago

Last modified 10 years ago

Save Scenario As... not working properly

Reported by: davec Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description

When I use Save Scenario As it will save the scenario under the new name that I specified, but when I go to open the new scenario I get these errors in the status window:

-Index was outside the bounds of the array, occurred while reading ForcingMatrix?
-Ecosim scenario Fitting_20080306 failed to load. Failed to read the database.

How I reproduced this error:

  1. open model and load scenario 1--ok
  2. load and apply time time series--ok
  3. run ecosim--ok
  4. Save Scenario As scenario 2--get message that ecosim scenario 1 has changed, do you wish to save these changes click no
  5. status window says ecosim scenario 2 has been saved
  6. File, close model--get message that 'ecosim scenario 2 has changed, do you wish to save these changes?`, click yes and model closes
  7. open model and load scenario 2--that's when I get the error messages above.

The two do you wish to save changes messages are confusing because I didn't make any changes. Also, I have done nothing with the ForcingMatrix? in going from scenario 1 to scenario 2.

Change History

comment:1 Changed 10 years ago by jeroens

Fixed after build 6.0.3.18

Note: See TracTickets for help on using tickets.