Ticket #455 (closed: fixed)

Opened 10 years ago

Last modified 10 years ago

Database open an Economos project (EwEcost.mdb) file -> Wrong prompt

Reported by: shermanl Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Plug-ins Version:
Severity: minor Keywords:
Cc:

Description

When you open a EwECost.mdb file with EwE6, you get the prompt:

This database was written by an outdated version of Ecopath 5, which is not supported by EwE6 import process

I personally think you should have a richer prompt message such as: You shouldn't be so dumb to open an Ecost.MDB with EwE6, but I don't think it'll go over well. ;)

Change History

comment:1 Changed 10 years ago by jeroens

The EwE database checker only validates the database version number from the UpdateLog? table. Ecost uses the same database engine as EwE6. When this engine finds a valid Ecopath 6 version number it thinks it's dealing with an EwE6 database.

To properly assess the function of a database the UpdateLog? may have to contain a different field, or the the database engine may have to test for the precense of specific tables. I'm not so sure how to solve this properly. I think the error is just fine 'cause it's indeed a pretty silly thing to attempt ;)

comment:2 Changed 10 years ago by jeroens

After build 6.0.4.2: just to finish this one off, I'll make the Ecost databases use an entirely different file extension. This is no longer an issue.

Note: See TracTickets for help on using tickets.