Ticket #473 (closed: not an issue)

Opened 11 years ago

Last modified 9 years ago

Ecosim may crash when saving TS data in older EwE6 databases

Reported by: jeroens Owned by: jeroens
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:
Cc:

Description (last modified by jeroens) (diff)

Symptom:
Application crashes when saving changes to Time Series.

Reproduce:

  • Open carie's 'Lab 3' test database
  • Load time series
  • Modify any time series data to flag the scenario as dirty
  • Save the scenario

Cause:
Database of EwE6 pre-release candidates cannot be updated using Microsoft Access SQL. The tables EcosimTimeSeriesGroup? and -Fleet in this particular database have a compound primary key which was changed prior to the September release. The EwE6 save sim scenario code expects only a singular primary key and crashes.

Solution:
None at this moment. Access SQL does not support dropping existing Primary Keys, so we cannot write an update to fix this issue.

Severity:
Low since the database schema was changed prior to the September 2007 release. However, I logged this issue just in case it were to surface unexectedly.

Change History

comment:1 Changed 11 years ago by jeroens

Just to keep on it

comment:2 Changed 9 years ago by jeroens

  • Owner set to jeroens
  • Status changed from new to assigned
  • Description modified (diff)

comment:3 Changed 9 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution changed from open to not an issue
Note: See TracTickets for help on using tickets.