Ticket #499 (closed assessed: fixed)

Opened 10 years ago

Last modified 9 years ago

I can't get the MTI image and Flow and Catch pyramids (Network analysis plug-in)

Reported by: martac Owned by: jeroens
Priority: normal Milestone: Ecopath 6: release 6.0.8
Component: Network Analysis plug-in Version:
Severity: minor Keywords:
Cc:

Description

When I use the Network analysis plug-in and I run the MTI, I can get the raw values but I can't get the image associated with it (bar-plot). I get the same problem with flow and catch pyramids.

Change History

comment:1 Changed 10 years ago by administrator

has duplicate #446

comment:2 Changed 10 years ago by joeh

The symptom of this bug is similar to that of bug 452 but I'm not sure the causes are the same. In bug 452, the user used a French OS and the , decimal separator was the culprit. Can I have the e-mail address of the reporter so that I could ask questions like (1) What OS is he using? (2) Did he get any error message such as file not found? etc

comment:3 Changed 10 years ago by shermanl

The culture issues with commas has been fixed. in version 6.0.3.15. Please test this out. :)

comment:4 Changed 10 years ago by jeroens

In response to the report by Marta (below) I suspect that this is a current working directory problem. It is worth trying to see whether restoring the 'current directory' to the 'application directory' prior to invoking the pyramid will solve the issue.

-- begin report --
I found the problem with the MTI and the pyramids ... the problem seems to be that when the database is too far away for the core program then the program does not find the application of MTI or pyramids. So I just saved my model in the same folder as ecopath.exe and then it works. I tried with the different versions of 6 that I had installed and the latest from Sherman links all all work, so this is it.
Marta
-- end report --

comment:5 Changed 10 years ago by jeroens

Ok, I narrowed the problem down to two issues:

  1. The current working directory must be set to the directory where pyramid.exe, fd.exe and impacts.exe reside
  2. The directory to these files can grow too long. In my case, it is not happy with E:\Visual Studio 2005\Projects\Ecopath\Ecopath6\Sources\ScientificInterface\bin\Debug\EwENetworkAnalysis, but C:\Ewe6NA works like a charm

Based on this, I propose to install the three Network Analysis apps in a directory straight off the root (thus outside the EwE6 installation directory) and run them from there. It's bad but really, using three 16-bit apps is not any better.

comment:6 Changed 10 years ago by shermanl

Sent email to Marta with subject: Bug with MTI/FlowCatch Pyramids

Waiting for her reply.

comment:7 Changed 9 years ago by jeroens

Duplicate of #648

comment:8 Changed 9 years ago by jeroens

  • Priority changed from low to normal
  • Severity changed from feature to minor

comment:9 Changed 9 years ago by shermanl

  • Type set to not assessed

comment:10 Changed 9 years ago by shermanl

  • Milestone changed from Ecopath 6: build 6.0.7 to Ecopath 6: build 6.0.8

comment:11 Changed 9 years ago by jeroens

  • Owner changed from shermanl to jeroens
  • Type changed from not assessed to assessed
  • Component changed from Ecopath to Network Analysis

comment:12 Changed 9 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution changed from repoened to fixed

Pyramids solved
Old MTI graph is included

Note: See TracTickets for help on using tickets.