Ticket #507 (closed: repoened)

Opened 10 years ago

Last modified 10 years ago

Ecospace Basemap Hangs/Slow

Reported by: shermanl Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecospace Version:
Severity: major Keywords:
Cc:

Description

Ecospace basemap seems to be unbelievably slow. Especially when you are adding many layers e.g. add 10 habitats, and 10 mpa's, it starts to hang and is impossible to modify.

Profiling to see where this will hang up will help significantly. Jeroen, you mentioned this was a problem already, but it will be helpful to look into this again before the release. See what you can do.

Change History

comment:1 Changed 10 years ago by carieh

So it is not just me and my slow computer :-)
Ha!!

comment:2 Changed 10 years ago by jeroens

Ok, this probably needs massive profiling on the drawing logic

comment:3 Changed 10 years ago by jeroens

Fixed after 6.0.3.18

Habitat, MPA and region additions will not slow the map significantly further anymore.

If you happen to use a big map (100 x 200 cells x 59 groups for instance) Ecospace has a brutal time starting up. This issue is logged as 420

comment:4 Changed 10 years ago by carieh

was that last comment a direct stab at me????
Still hanging the basemap when I add 10 habitats :-)
and YES I am using my model with 59 groups, but I am using a rather small basemap 10x10 with 10km cells

And just for reference I used a small model 5 groups (lab 1)using 10x10 and 10km cells. This also causes the model to pause.
version 6.0.4

the good news is the program doesn't crash, just takes a while

comment:5 Changed 10 years ago by jeroens

Slow Ecosapce performance on startup is dealt with in issue 420; the performance issues described in 517 are fixed.

Note: See TracTickets for help on using tickets.