Ticket #519 (closed: fixed)

Opened 10 years ago

Last modified 10 years ago

Ecopath> Edit groups certain letters cause actions in `group name` category

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecopath Version:
Severity: minor Keywords:
Cc:

Description

To re-create
-create model
-go ecopath (on top toolbar)> edit groups
-insert a bunch of groups (10+)
-double click on the first group to enter a name
-enter the letter a only
-click enter
-click down arrow (it is important NOT to double click into a cell but to use the down arrow)
-enter the letter b only
-click enter and move down to next cell
-continue through alphabet..you will find certain letters cause actions when used in this manner... c causes the color screen to pop-up, d causes the group to move down, u moves it up, etc.

I showed Sherman and he thinks it is just a problem with the functions on the right side of the interface having a precedent over the lettering. I am not sure which of the letters actually cause these changes, I have just noticed a few.

Change History

comment:1 Changed 10 years ago by jeroens

The problem are the shortcut keys under the buttons vs. the focus of the grid. Wehn you press 'Alt' you'll see which keys the dialog responds to whenever a grid cell no longer has the focus.

The problem is known and is Windows default behaviour (http://www.eggheadcafe.com/forumarchives/vcmfc/jan2006/post25308139.asp) that we must find some kind of work-around for

comment:2 Changed 10 years ago by jeroens

Apparently, quite a few people have problems with this. .NET behaves differently from VB 6.0 here: shortcut keys (Alt + Key) enabled controls also consume the Key press (without Alt pressed!) when no clear focus is defined. Unfortunately, the grid's control over focus is not hard enough.

The only solution to this is to somehow try to override how our forms handle shortcut key presses. I'm digging in further.

comment:3 Changed 10 years ago by jeroens

After build 6.0.4.5: removed Alt shortcut keys from dialogs

comment:4 Changed 10 years ago by carieh

version 6.0.4.6
These issues are still happening :-(
Sorry. I dont know how big of an issue it is for you. If you double click into each of the cells then the shortcut keys are not a problem, only if you try to edit a bunch a names and click enter in between.

Note: See TracTickets for help on using tickets.