Ticket #542 (closed: fixed)

Opened 10 years ago

Last modified 9 years ago

Ecopath landings dirty flag

Reported by: villyc Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecopath Version:
Severity: minor Keywords:
Cc:

Description

Deleting a landing in Ecopath doesn't enable the 'Save' in menu, so a dirty flag is missing

Also, deleting a landing value, removes it from the spread, but once saved and reloaded the value is still there

Change History

comment:1 Changed 10 years ago by jeroens

6.0.4.5: unable to duplicate; under 'normal' circumstances I cannot reproduce this bug. Maybe something else went wrong before the bug surfaced?

comment:2 Changed 10 years ago by carieh

Ok I think I am having the same issue that Villy found. To replicate
-open a model
-open landings interface in Ecopath
-delete a number (landings from one of the fleets)
-close model: note you will NOT be prompted if you want to save changes you have made
-reopen model: there will be the original values including the one you just deleted.

comment:3 Changed 10 years ago by jeroens

Thanks for the info, but no luck:

  • opened new model
  • went straight to landings (input data>fishery>landings)
  • delete any of the landings values

Immediately, the status bar Ecopath icon says 'modified'.

  • closing EwE or selecting 'Menu>file>close model' will invoke the save prompt dialog.

Very strange...

Note: See TracTickets for help on using tickets.