Ticket #553 (closed: fixed)

Opened 10 years ago

Last modified 10 years ago

Ecopath cannot mass balance with immigration

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Contaminant tracing Version:
Severity: minor Keywords:
Cc:

Description

So nobody wants to hear this, but I created model lab1-Oct27_ver2
If you add in all the parameters to make it exactly like the version 5 model it will NOT balance, you get an error (pop-up) that says
Ecopath failed to estimate one or more parameters
EE could not be estimated for group 1
Ecopath failed to run

and then the status bar gives you the same thing.

I think this is due to the fact that there is immigration to group one in the other production interface. If you remove the immigration (set it =0) then the model balances and you can get to the output parameters. If you add the immigration back in then it will not run and gives you the same errors again.

Change History

comment:1 Changed 10 years ago by joeb

Hi Carie

Ive look at this. When I entered the values from your 6 database back into 5 I get the same problem , the model will not balance in either version. Once I entered a value for Catch in both 5 and 6 then the model balances in both versions. Try that and see if it works for you. Enter a value for Catch into 6 and see if it works. There is a warning message in both 5 and 6 about zero catch but the message in 6 only appeared in the status window it did not popup in your face so it was easy to miss. Ive change this in 6.

joe

comment:2 Changed 10 years ago by carieh

Hi Joe,
Ok I can also get the model to crash in the following scenarios
-immigration >0, no landings, and market price for other fish =1

I know this scenario doesnt really make sense, but I was playing around (why have a fishery if you are not catching anything)

-After changing the parameters around back and forth a few times, the model will not even balance with catches, non-market price=1, and immigration. I much have screwed up the program.

Either way, we need to be able to have the model balance without having to add in a non-market price.

comment:3 Changed 10 years ago by joeb

Hi Carie
I can not re-create this configuration in the current version EwE6 (6.0.4.6) so I'm not sure what to do here. See if you can reproduce this with the latest version then if you can send me the model and I can try to tell what happened??? If not then I guess this went away...

Note: See TracTickets for help on using tickets.