Ticket #574 (closed assessed: fixed)

Opened 9 years ago

Last modified 8 years ago

Network Analysis: cannot open pyramids

Reported by: martac Owned by: jeroens
Priority: normal Milestone: Ecopath 6: release 6.0.8
Component: Ecopath Version:
Severity: major Keywords: Network analysis, pyramid
Cc:

Description (last modified by shermanl) (diff)

An exception occurs when trying to open any of the pyramids in build 6.0.5.0
(flows & biomass > Summ of flows > data > pyramid(s)

Change History

comment:1 Changed 9 years ago by jeroens

Sherm, I'd say either rewrite these as a control and stick it in ScientificInterfaceShared?, or get rid of the pyramids. What do you think?

comment:2 follow-up: ↓ 3 Changed 9 years ago by shermanl

  • Description modified (diff)

I think this is a good idea for the following reasons:
1) 16bit applications does not run on 64bit Win7
2) It's easier to rewrite than debug.
3) Best usage of this pyramid is to compare between scenarios.

comment:3 in reply to: ↑ 2 Changed 9 years ago by shermanl

Note: computational algorithm and basic drawing has been done externally here:
Ecopath6_Internal\TestProjects?\Pyramid

Just needs to port it.

comment:4 Changed 8 years ago by jeroens

Duplicate of #648

comment:5 Changed 8 years ago by shermanl

  • Type set to not assessed

comment:6 Changed 8 years ago by jeroens

  • Type changed from not assessed to assessed

comment:7 Changed 8 years ago by jeroens

  • Keywords Network analysis, pyramid added

comment:8 Changed 8 years ago by shermanl

  • Milestone changed from Ecopath 6: build 6.0.7 to Ecopath 6: build 6.0.8

comment:9 Changed 8 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution changed from open to fixed

Pyramids open again by using 8.3 paths to the network analysis text files

comment:10 Changed 8 years ago by jeroens

Found and fixed a bug today. Only the Flow pyramid was correctly invoked on 8.3 paths, the other two were happily using the 'long' paths.

Note: See TracTickets for help on using tickets.