Ticket #607 (closed: fixed)

Opened 10 years ago

Last modified 9 years ago

Database update: Not fired when double clicking on MDB file

Reported by: shermanl Owned by: shermanl
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Overall GUI Version:
Severity: minor Keywords:
Cc:

Description (last modified by jeroens) (diff)

Database update prompt is not invoked when you double click on the mdb file (that has not been updated). Prompt will only come if you start EwE6 first then open the model.

Change History

comment:1 Changed 10 years ago by jeroens

The Scientific Interface always checks whether a database needs to be updated when loading a model, regardless how the load command arrived. The core itself does NOT perform this check; the test is initiated by AppLauncher? because of user interactions that are required to perform a database update.

This behaviour is by design.

In brief, stand-alone cores such as used in the game engine will not attempt to update a database, only the ScInt? will. It is possible to bring this behaviour into the core but that involves work.

What is expected?

comment:2 Changed 9 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution changed from open to fixed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.