Ticket #620 (closed assessed: fixed)

Opened 9 years ago

Last modified 9 years ago

Fishing effort shapes in the SI interface don't update when changing Ecosim scenarios

Reported by: joeb Owned by: villyc
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: minor Keywords:
Cc:

Description (last modified by shermanl) (diff)

Load a model that has multiple Ecosim scenarios. Edit one of the fishing effort shapes and save the scenario. Load a different Ecosim scenario. The newly loaded scenario effort shape will still look the same as the edited one from the previous scenario. Fishing effort shapes are save by scenario and should change when the scenario is changed.
I'm not sure if this is just an updating problem in the interface/core or if the shapes are not reloading correctly with the new scenario.

Change History

comment:1 Changed 9 years ago by jeroens

Shapes are not saved per scenario by design. This is different from EwE5.

comment:2 Changed 9 years ago by jeroens

The current behaviour - that shapes are shared between Ecosim scenarios - is a big problem for restoring earlier EwE game states. In order to satisfy game requirements we could make shapes scenario dependent again. This would mean quite a lot of work:

  • changing the database structure
  • changing the timing of loading/saving shapes
  • changing the database importer

This should be discussed with VC

comment:3 Changed 9 years ago by shermanl

  • Type set to not assessed
  • Description modified (diff)

comment:4 Changed 9 years ago by jeroens

  • Status changed from assigned to closed
  • Type changed from not assessed to assessed
  • Resolution changed from not an issue to fixed

This was related to a few recently closed bugs where Effort shapes were shared between scenarios. No longer an issue.

Note: See TracTickets for help on using tickets.