Ticket #623 (closed assessed: not an issue)

Opened 9 years ago

Last modified 8 years ago

Timeseries datasets with forcing function data (eTimeSeriesType.TimeForcing) are not applied when timeseries dataset is loaded

Reported by: joeb Owned by: villyc
Priority: normal Milestone: Ecopath 6: release 6.2
Component: Ecosim Version:
Severity: major Keywords:
Cc:

Description (last modified by jeroens) (diff)

In EwE5 when a timeseries dataset is loaded that contains type 2 data (in EwE5 time forcing in EwE6 TimeSeriesType?.TimeForcing?) this data will overwrite any existing forcing function data in memory. In EwE6 when the database is imported timeseries data of type 2 data (time forcing) are striped out of the timeseries dataset and loaded into the forcing function data. Then if the timeseries dataset is loaded/applied the forcing function data never gets applied so the in memory forcing function data does not contain the timeseries data from the dataset.

This creates differences in the Ecosim output if timeseries data that includes forcing function data are loaded

In EwE5 once timeseries data that contains forcing function data is loaded that data stays in memory until a new model is loaded, even if another timeseries dataset is loaded. This effectively corrupts forcing function data that has been applied.

Change History

comment:1 Changed 9 years ago by jeroens

  • Owner set to jeroens
  • Status changed from new to assigned
  • Description modified (diff)

comment:2 Changed 9 years ago by jeroens

  • Owner changed from jeroens to villyc

We'll need to sort out how to address fix this. Reverting to the EwE5 way might be best, but Villy wanted this changed to its current behaviour.

Once a TS is imported as a forcing shape, it no longer is a time series and thus will not be applied when time series are loaded. That is quite simple.

comment:3 Changed 8 years ago by shermanl

  • Type set to not assessed

comment:4 Changed 8 years ago by shermanl

  • Milestone changed from Ecopath 6: build 6.0.7 to Ecopath 6: build 6.0.8

comment:5 Changed 8 years ago by shermanl

  • Owner villyc deleted

comment:6 follow-up: ↓ 8 Changed 8 years ago by jeroens

  • Type changed from not assessed to assessed

Two possible solutions:

  1. On TS import, add prompt which forcing function to overwrite, provide most likely candidate, and allow user to create a new FF for this.
  2. Revert to EwE5 behaviour by NOT converting a Forcing TS to a FF.

comment:7 Changed 8 years ago by jeroens

  • Owner set to villyc

comment:8 in reply to: ↑ 6 Changed 8 years ago by jeroens

Replying to jeroens:

Two possible solutions: 

  1. On TS import, add prompt which forcing function to overwrite, provide most likely candidate, and allow user to create a new FF for this. 
  2. On TS import, add prompt which forcing function to affect, but DO NOT convert the TS to a FF. Instead, only overwrite an FF in memory.

comment:9 Changed 8 years ago by jeroens

Duplicate of #617

comment:10 Changed 8 years ago by jeroens

  • Milestone changed from Ecopath 6: build 6.0.8 to Ecopath 6: build 6.1.1

comment:11 Changed 8 years ago by jeroens

  • Milestone changed from Ecopath 6: release 6.1.1 to Ecopath 6: release 6.2

comment:12 Changed 8 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution changed from open to not an issue
Note: See TracTickets for help on using tickets.