Ticket #673 (closed assessed: fixed)

Opened 8 years ago

Last modified 8 years ago

Crashing model

Reported by: shermanl Owned by: jeroens
Priority: high Milestone: Ecopath 6: release 6.0.8
Component: Ecopath Version:
Severity: crash Keywords:
Cc:

Description

On Robbie's computer, it stalls as soon as you try mass balance it (after all the pop up messages). I can't reproduce it on my dev environment or the installation build he used 6.0.7.206 and 210. The only difference is that he's using XP. :(

NOTE: this model is very different where it has 4 groups with 100% import, and several message boxes pops up warning you of this.

Attachments

SGMARAECO.zip (87.2 KB) - added by shermanl 8 years ago.

Change History

Changed 8 years ago by shermanl

comment:1 Changed 8 years ago by jeroens

  • Priority changed from NOT SET to high
  • Type changed from NOT SET to assessed

comment:2 Changed 8 years ago by jeroens

Unable to reproduce, could be related to #672

comment:3 Changed 8 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to unable to duplicate

comment:4 Changed 8 years ago by shermanl

  • Status changed from closed to reopened
  • Resolution unable to duplicate deleted

I found an XP computer (sherman.ecopath.org) that crashes when paramatizing this model, but this only happens under the running EwE6 in the Bin folder in the Release environment.  I tried attaching the development environment after running the EwE6, and it goes dead in the water.  Any ideas?

comment:5 Changed 8 years ago by jeroens

Release mode ran outside the Dev environment indeed seems to have this problem.

  • Excluding plug-ins does not make a difference

Strategy: decrease amount of debug info in assembly to see where this fails.

comment:6 Changed 8 years ago by jeroens

Ok, I found the cause of this issue. To crash is due to the use of CheckedMessageBox?, a standard message box that was extended via windows hooks to add a 'do not ask me again' prompt. Rob's model repeatedly caused this box to appear, causing EwE6 to crash. Removing the checkedmessagebox also removed the problem.

..but this eliminates the option for users to suppress repeated prompts.

comment:7 Changed 8 years ago by jeroens

To solve the repeated prompts issue, either the CheckedMessageBox? class needs to be debugged (the issue seems to be related to trying to obtain the win32 thread ID), or a new message box form needs to be built from scratch.

comment:8 Changed 8 years ago by jeroens

  • Status changed from reopened to closed
  • Resolution set to fixed

For now, repeated messages cannot be suppressed until a more stable solution than the current extension of the OS MessageBox? is available.

Note: See TracTickets for help on using tickets.