Ticket #680 (closed assessed: fixed)

Opened 9 years ago

Last modified 9 years ago

Closing a model with torn-off plug-in forms will not close these forms

Reported by: jeroens Owned by: jeroens
Priority: normal Milestone: Ecopath 6: release 6.0.8
Component: Overall GUI Version:
Severity: crash Keywords: dock panel, close model
Cc:

Description (last modified by jeroens) (diff)

To reproduce:

  • Load a model
  • Load value chain plug-in
  • Drag the value chain plug-in form out of the EwE6 user interface (undock the plug-in form)
  • Close the model

The value chain form will not close

Furthermore, closing the value chain form manually will result in debug assertions because the underlying model has already disappeared.

Change History

comment:1 Changed 9 years ago by jeroens

  • Description modified (diff)

comment:2 Changed 9 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to fixed

Unable to reproduce with latest version; was probably a value chain issue that has gone away with recent fixes to the plug-in. The framework behaves correctly.

Note: See TracTickets for help on using tickets.